Widget New Incident

Resolved
Major outage
Started 3 months ago Lasted 29 minutes

Affected

Widget
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We are currently investigating this incident.